Widget Channel
Incident Report for HiJiffy
Resolved
This incident has been resolved.
Posted Nov 14, 2023 - 17:49 UTC
Update
We are continuing to investigate this issue.
Posted Nov 14, 2023 - 17:48 UTC
Investigating
Pusher
Posted Nov 14, 2023 - 17:48 UTC
This incident affected: Widget.